Expert Sleepers and Leopard

I thought it was high time I put up some sort of statement about Leopard compatibility.

The current situation is this: all Expert Sleepers plug-ins are currently officially untested in Leopard. I have no reason to suppose that they won't work, but you never know. I've had a couple of reports of problems, but I get that all the time on all OSs (and the problems are almost always resolvable, and due to local installation issues). I've had more reports of the plug-ins working fine in Leopard.

So why officially untested? I've been waiting for Leopard to be a bit more stable before moving to it. It's a small operation here and I don't have the luxury of multiple Macs to test different configurations, and I need to keep my development machine stable at all costs. Based on the vibe on the web so far, I'm glad to have avoided 10.5.0 and 10.5.1.

Therefore, the current plan is to wait for 10.5.2 and then move over development (and therefore testing) to Leopard at that time.

If anyone is using Expert Sleepers stuff on Leopard, I'd love to hear of your experiences, positive or otherwise.