Augustus Loop v2.3.0 released - 64 bit Mac VST

We’re proud to announce the release of Augustus Loop v2.3.0.

The headline here is that this is our first 64 bit Mac OS X VST, and so is usable without a ‘bridge’ in apps such as the 64 bit version of Reaper, and will be usable in any forthcoming 64 bit Mac release of Cubase.

The AU and Windows VST versions are also updated. Full change list:

* First 64 bit Mac OS X VST release.
* Improved handling of mouse events (dragging knobs would temporarily freeze the host UI on some platforms).
* Improved accuracy of MIDI event handling.

Download now from the downloads page.

Latency Fixer v1.0.3 released - 64 bit AU, plus VST versions

Latency Fixer v1.0.3 is released.

The AU version is now a 32/64 bit Intel-only build for OS X 10.5 and above.

Mac OS X and Windows VST versions are also now available - previously the plug-in was AU-only.

Download now from the downloads page.

Oomingmak v1.1.0 released - 64 bit AU

Oomingmak v1.1.0 is released. This is a 32/64 bit Intel-only release. Only the AU version is updated. There are no other changes, so unless you need the 64 bit functionality, you do not need this update.

Download now from the downloads page.

Augustus Loop v2.2.1 (AU) released

Augustus Loop v2.2.1 is released. This is a bugfix release addressing some issues with the previous version (v2.2.0). As before, this is a 32/64 bit Intel only release for OS X 10.5 and above, so you only need this update if you specifically need the 64 bit functionality.

Issues addressed in this release:
- Fixed compatibility with OS X 10.5.
- Worked around a bug in Digital Performer 7.1 which would cause a crash when the plug-in prefs dialog was used.
- Generally improved stability of the Cocoa UI.

Download now from the downloads page.

Augustus Loop v2.2.0 released - 64 bit AU

We’re proud to announce the release of Augustus Loop v2.2.0.

This is a milestone for Expert Sleepers as it’s our first 64 bit release. Specifically it’s a 32/64 bit Intel Audio Unit, and so can be used in native 64 bit mode in Logic 9 and Mainstage 2.1 when those hosts are running as 64 bit applications.

From now on we anticipate that all our Mac releases will be Intel only, will support 64 bit use, and will require Mac OS X 10.5 or 10.6.

There are no new features in Augustus Loop v2.2.0 other than the availability of a 64 bit variant. If you’re not using 64 bit hosts, there’s no reason to take this update.

If you are though, download the update now from the downloads page.

Update: there appears to be a problem with this version’s GUI and Digital Performer. Please use v2.1.2 with Digital Performer (which is 32 bit, so there’s no reason to use this 64 bit build anyway).

Update: MOTU have confirmed this problem in DP 7.1.

Update: there is also a problem with this version and OS X 10.5. A fix is being worked on.

Logic 9.1 64 bit compatibility

Good news - all Expert Sleepers plug-ins appear to work fine under Logic 9.1’s 32 bit Audio Unit Bridge, when running Logic in 64 bit mode.

The one slight oddity is when clicking on text boxes in order to type values into the GUIs. Normally this requires a single click to activate the text field (at which point it goes green) - when running under the 32 bit bridge, it requires a double click. Other than that, everything works normally.

If you experience any oddness when using the 32 bit bridge, let us know.